p5-Perl-MinimumVersion-1.38nb4.tgz


Advertisement

Description

p5-Perl-MinimumVersion - Find a minimum required version of perl for Perl code

Property Value
Distribution NetBSD 7.1
Repository NetBSD amd64
Package name p5-Perl-MinimumVersion
Package version 1.38nb4
Package architecture amd64
Package type tgz
Package license gnu-gpl-v2 OR artistic
Installed size 62.07 KB
Download size 16.76 KB
Official Mirror ftp.netbsd.org
Perl::MinimumVersion takes Perl source code and calculates the minimum
version of perl required to be able to run it. Because it is based on
PPI, it can do this without having to actually load the code.
Currently it tests both the syntax of your code, and the use of explicit
version dependencies such as require 5.005.
Homepage: http://search.cpan.org/dist/Perl-MinimumVersion/
Categories: devel, perl5

Alternatives

Package Version Architecture Repository
p5-Perl-MinimumVersion-1.38nb4.tgz 1.38nb4 i386 NetBSD
p5-Perl-MinimumVersion - - -

Requires

Name Value
p5-File-Find-Rule >=0.32
p5-File-Find-Rule-Perl >=1.04
p5-PPI >=1.215
p5-PPIx-Regexp >=0.033
p5-Params-Util >=0.25
p5-Perl-Critic >=1.104
perl >=5.28.0<5.30.0

Download

Type URL
Binary Package p5-Perl-MinimumVersion-1.38nb4.tgz
Source Package p5-Perl-MinimumVersion

Install Howto

Install p5-Perl-MinimumVersion tgz package:

# pkg_add p5-Perl-MinimumVersion

See Also

Package Description
p5-Perl-PrereqScanner-1.023nb4.tgz Tool to scan your Perl code for its prerequisites
p5-Perl-Tidy-20181120.tgz Parses and beautifies perl source
p5-Perl-Version-1.013nb4.tgz Perl 5 module to parse and manipulate Perl version strings
p5-Perl4-CoreLibs-0.004nb1.tgz Libraries historically supplied with Perl 4
p5-Perl6-Export-0.009nb2.tgz Implements the Perl 6 'is export(...)' trait
p5-Perl6-Export-Attrs-0.000006nb1.tgz Perl 5 module implementing Perl 6 symbol export mechanism
p5-Perl6-Junction-1.60000nb4.tgz Perl6 style Junction operators in Perl5
p5-Perl6-Slurp-0.051005nb4.tgz Implements the Perl 6 'slurp' built-in
p5-PerlIO-eol-0.17nb1.tgz Perl module for normalizing line endings
p5-PerlIO-gzip-0.20nb1.tgz Perl extension to provide a PerlIO layer to gzip/gunzip
p5-PerlIO-utf8_strict-0.007nb2.tgz Perl extension to provide fast and correct UTF-8 I/O
p5-PerlIO-via-Bzip2-0.02nb8.tgz PerlIO layer for Bzip2 (de)compression
p5-PerlIO-via-Timeout-0.32nb3.tgz PerlIO layer to add read and write timeouts to a handle
p5-PerlIO-via-dynamic-0.14nb6.tgz Perl module for dynamic PerlIO layers
p5-PerlIO-via-symlink-0.05nb10.tgz PerlIO layers to create symlinks
Advertisement
Advertisement