polly-8.0.0.tgz


Advertisement

Description

polly - Polyhedral optimizations for LLVM

Property Value
Distribution NetBSD 8.0
Repository NetBSD amd64
Package filename polly-8.0.0.tgz
Package name polly
Package version 8.0.0
Package release -
Package architecture amd64
Package type tgz
Category devel
Homepage http://polly.llvm.org/
License modified-bsd
Maintainer -
Download size 2.37 MB
Installed size 16.83 MB
Polly is a high-level loop and data-locality optimizer and optimization
infrastructure for LLVM. It uses an abstract mathematical representation based
on integer polyhedra to analyze and optimize the memory access pattern of a
program. We currently perform classical loop transformations, especially tiling
and loop fusion to improve data-locality. Polly can also exploit OpenMP level
parallelism, expose SIMDization opportunities. Work has also be done in the
area of automatic GPU code generation.
For many users, however, it's not the existing optimizations in Polly that are
of most interest, but the new analyses and optimizations enabled by the Polly
infrastructure. At polyhedral.info you can get an idea of what has already been
done and what is possible in the context of polyhedral compilation.

Alternatives

Package Version Architecture Repository
polly-8.0.0.tgz 8.0.0 i386 NetBSD
polly - - -

Requires

Name Value
llvm >= 8.0.0
llvm-8.0.0 -

Download

Type URL
Mirror ftp.netbsd.org
Binary Package polly-8.0.0.tgz
Source Package polly

Install Howto

Install polly tgz package:

# pkg_add polly

See Also

Package Description
polyglot-1.4.tgz UCI to WB adapter (for chess engines)
polysh-0.4nb2.tgz Aggregate several remote shells into one
popa3d-1.0.3.tgz Secure, reliable, performant, and small pop3 server
poppassd-4.1.0.tgz Qualcomm's password change server mainly for Eudora
poppler-0.76.1.tgz PDF rendering library
poppler-cpp-0.76.1.tgz PDF rendering library (cpp wrapper)
poppler-data-0.4.9.tgz Support files for poppler
poppler-glib-0.76.1.tgz PDF rendering library (GLib wrapper)
poppler-includes-0.76.1.tgz Poppler Xpdf includes (unsupported)
poppler-qt5-0.76.1.tgz PDF rendering library (QT5 wrapper)
poppler-utils-0.76.1.tgz PDF utilities (from poppler)
poppy-4.01nb5.tgz Client to perform simple tasks with a POP3/IMAP server
popt-1.16nb2.tgz Command line option parsing library
poptop-1.3.4nb1.tgz PPTP server with support for Microsoft VPN clients
port2pkg-1.15nb5.tgz Convert from a FreeBSD port to a NetBSD package
Advertisement
Advertisement