libpeas-1.24.1.tgz


Advertisement

Description

libpeas - GObject-based plugins engine

Property Value
Distribution NetBSD 8.1
Repository NetBSD i386
Package filename libpeas-1.24.1.tgz
Package name libpeas
Package version 1.24.1
Package release -
Package architecture i386
Package type tgz
Category devel gnome
Homepage https://wiki.gnome.org/Projects/Libpeas
License gnu-lgpl-v2.1
Maintainer -
Download size 118.94 KB
Installed size 638.14 KB
libpeas is a gobject-based plugins engine, and is targetted at
giving every application the chance to assume its own extensibility.
It also has a set of features including, but not limited to:
* multiple extension points
* on demand (lazy) programming language support for C, Python and JS
* simplicity of the API

Alternatives

Package Version Architecture Repository
libpeas-1.24.1.tgz 1.24.1 amd64 NetBSD
libpeas - - -

Requires

Name Value
glib2 >= 2.38.0
gobject-introspection >= 1.39.0
gtk3+ >= 3.24.8nb2
hicolor-icon-theme >= 0.9nb1
python37 >= 3.7.0

Download

Type URL
Mirror ftp.netbsd.org
Binary Package libpeas-1.24.1.tgz
Source Package libpeas

Install Howto

Install libpeas tgz package:

# pkg_add libpeas

Files

Path
/usr/pkg/lib/libpeas-1.0.so
/usr/pkg/lib/libpeas-1.0.so.0
/usr/pkg/lib/libpeas-1.0.so.0.2400.1
/usr/pkg/lib/libpeas-gtk-1.0.so
/usr/pkg/lib/libpeas-gtk-1.0.so.0
/usr/pkg/lib/libpeas-gtk-1.0.so.0.2400.1
/usr/pkg/lib/peas-demo/plugins/helloworld/libhelloworld.so
/usr/pkg/lib/peas-demo/plugins/secondtime/libsecondtime.so

See Also

Package Description
libpgf-6.14.12.tgz Progressive Graphics File (PGF) library
libpgm-5.1.118nb7.tgz PGM reliable multicast library implementing RFC 3208
libphutil-20170609nb1.tgz Collection of utility classes and functions for PHP
libpinyin-1.0.0.tgz Library to deal with pinyin
libplist-1.12nb1.tgz Handle Apple Binary and XML Property Lists
libportlib-1.01.tgz Portable file locking and directory reading
libpqxx-6.2.2nb1.tgz C++ interface to postgresql-lib
libprelude-0.9.24.1nb19.tgz LibPrelude libraries and c++ easy bindings
libprelude-lua-0.9.24.1nb13.tgz Lua bindings to LibPrelude
libprelude-perl-0.9.24.1nb18.tgz Perl bindings to LibPrelude
libprelude-python-0.9.24.1nb13.tgz Python bindings to LibPrelude
libpreludedb-0.9.15.3nb15.tgz Provides an interface to the database used to store IDMEF alerts
libpreludedb-mysql-0.9.15.3nb18.tgz Provides an interface to the database used to store IDMEF alerts
libpreludedb-perl-0.9.15.3nb18.tgz Provides an interface to the database used to store IDMEF alerts
libpreludedb-pgsql-0.9.15.3nb18.tgz Provides an interface to the database used to store IDMEF alerts
Advertisement
Advertisement